v7: Need new premium license? [EDIT2: Upgrading Java fixed it]

Post your Server Bug Report
garyo
Posts: 49
Joined: 10 Sep 2015, 01:47
Has thanked: 5 times
Been thanked: 15 times

v7: Need new premium license? [EDIT2: Upgrading Java fixed it]

Unread post by garyo » 29 Apr 2019, 15:46

I have a paid-up Madsonic premium license (on subscription). I just updated to v7 (smooth & totally painless), and notice it's not enabled for Premium. Went to enter my license key, and it says it's invalid. Does V7 need a new license? I had the server resend my key, but it's the same one.
Last edited by garyo on 17 May 2019, 17:05, edited 3 times in total.

garyo
Posts: 49
Joined: 10 Sep 2015, 01:47
Has thanked: 5 times
Been thanked: 15 times

Re: v7: Need new premium license?

Unread post by garyo » 29 Apr 2019, 15:51

Aha, I bet this error from the log is helpful:

Code: Select all

[2019-04-29 10:35:04,824] WARN SettingsService - Failed to validate license.
javax.net.ssl.SSLHandshakeException: sun.security.validator.ValidatorException: PKIX path building failed
: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to
requested target
        at sun.security.ssl.Alerts.getSSLException(Alerts.java:192)
        at sun.security.ssl.SSLSocketImpl.fatal(SSLSocketImpl.java:1949)
        at sun.security.ssl.Handshaker.fatalSE(Handshaker.java:302)
        at sun.security.ssl.Handshaker.fatalSE(Handshaker.java:296)
        at sun.security.ssl.ClientHandshaker.serverCertificate(ClientHandshaker.java:1509)
        at sun.security.ssl.ClientHandshaker.processMessage(ClientHandshaker.java:216)
        at sun.security.ssl.Handshaker.processLoop(Handshaker.java:979)
        at sun.security.ssl.Handshaker.process_record(Handshaker.java:914)
        at sun.security.ssl.SSLSocketImpl.readRecord(SSLSocketImpl.java:1062)
        at sun.security.ssl.SSLSocketImpl.performInitialHandshake(SSLSocketImpl.java:1375)
        at sun.security.ssl.SSLSocketImpl.startHandshake(SSLSocketImpl.java:1403)
        at sun.security.ssl.SSLSocketImpl.startHandshake(SSLSocketImpl.java:1387)
        at org.apache.http.conn.ssl.SSLConnectionSocketFactory.createLayeredSocket(SSLConnectionSocketFac
tory.java:436)
        at org.apache.http.conn.ssl.SSLConnectionSocketFactory.connectSocket(SSLConnectionSocketFactory.java:384)
        at org.apache.http.impl.conn.DefaultHttpClientConnectionOperator.connect(DefaultHttpClientConnectionOperator.java:142)
        at org.apache.http.impl.conn.PoolingHttpClientConnectionManager.connect(PoolingHttpClientConnectionManager.java:374)
        at org.apache.http.impl.execchain.MainClientExec.establishRoute(MainClientExec.java:393)
        at org.apache.http.impl.execchain.MainClientExec.execute(MainClientExec.java:236)
        at org.apache.http.impl.execchain.ProtocolExec.execute(ProtocolExec.java:186)
        at org.apache.http.impl.execchain.RetryExec.execute(RetryExec.java:89)
        at org.apache.http.impl.execchain.RedirectExec.execute(RedirectExec.java:110)
        at org.apache.http.impl.client.InternalHttpClient.doExecute(InternalHttpClient.java:185)
        at org.apache.http.impl.client.CloseableHttpClient.execute(CloseableHttpClient.java:72)
        at org.apache.http.impl.client.CloseableHttpClient.execute(CloseableHttpClient.java:221)
        at org.apache.http.impl.client.CloseableHttpClient.execute(CloseableHttpClient.java:165)
        at org.apache.http.impl.client.CloseableHttpClient.execute(CloseableHttpClient.java:140)
        at org.madsonic.service.SettingsService.validateLicense(SettingsService.java:3099)
        at org.madsonic.service.SettingsService$1.run(SettingsService.java:3122)
        at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
        at java.util.concurrent.FutureTask.runAndReset(FutureTask.java:308)
        at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$301(ScheduledThreadPoolExecutor.java:180)
        at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:294)
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
        at java.lang.Thread.run(Thread.java:745)
Caused by: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
        at sun.security.validator.PKIXValidator.doBuild(PKIXValidator.java:387)
        at sun.security.validator.PKIXValidator.engineValidate(PKIXValidator.java:292)
        at sun.security.validator.Validator.validate(Validator.java:260)
        at sun.security.ssl.X509TrustManagerImpl.validate(X509TrustManagerImpl.java:324)
        at sun.security.ssl.X509TrustManagerImpl.checkTrusted(X509TrustManagerImpl.java:229)
        at sun.security.ssl.X509TrustManagerImpl.checkServerTrusted(X509TrustManagerImpl.java:124)
        at sun.security.ssl.ClientHandshaker.serverCertificate(ClientHandshaker.java:1491)
        ... 30 more
Caused by: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
        at sun.security.provider.certpath.SunCertPathBuilder.build(SunCertPathBuilder.java:141)
        at sun.security.provider.certpath.SunCertPathBuilder.engineBuild(SunCertPathBuilder.java:126)
        at java.security.cert.CertPathBuilder.build(CertPathBuilder.java:280)
        ...
 
 Missing cert files perhaps?
 My madsonic instance has full access to the public Internet, FYI.


garyo
Posts: 49
Joined: 10 Sep 2015, 01:47
Has thanked: 5 times
Been thanked: 15 times

Re: v7: Need new premium license? [EDIT: failed to validate lic]

Unread post by garyo » 08 May 2019, 21:41

Anything on this? Are other v7 testers seeing properly activated Premium?

KaeTuuN
Posts: 38
Joined: 09 Feb 2015, 23:30
Has thanked: 5 times
Been thanked: 17 times

Re: v7: Need new premium license? [EDIT: failed to validate lic]

Unread post by KaeTuuN » 09 May 2019, 14:50

I have no issues verifying my license.

Greetings Kae

PS: Next time please use the "Bug Header" so it is easier for everyone to help you.

mtnkodiak
Posts: 6
Joined: 19 Feb 2013, 05:50
Has thanked: 0
Been thanked: 1 time

Re: v7: Need new premium license? [EDIT: failed to validate lic]

Unread post by mtnkodiak » 10 May 2019, 01:20

I also have no problem activating my premium upon v7 upgrade. I have seen the dreaded PKIX path building error before, when doing some SSL work at a previous job... I seem to recall it was a configuration issue on my end, but it was a while ago.

User avatar
Madsonic
Administrator
Administrator
Posts: 960
Joined: 07 Dec 2012, 03:58
Has thanked: 1147 times
Been thanked: 449 times

Re: v7: Need new premium license? [EDIT: failed to validate lic]

Unread post by Madsonic » 10 May 2019, 18:16

Please look here for a possible solution: viewtopic.php?f=75&t=2649#p8355

Best regards,
The Madsonic Team
These users thanked the author Madsonic for the post:
garyo

garyo
Posts: 49
Joined: 10 Sep 2015, 01:47
Has thanked: 5 times
Been thanked: 15 times

Re: v7: Need new premium license? [EDIT: failed to validate lic]

Unread post by garyo » 10 May 2019, 19:15

Hmm, upgrading Java in my jail is going to take some work. The jail is quite old now, Freebsd 9 if I remember. And yes, all the cacerts files on that machine are old.

garyo
Posts: 49
Joined: 10 Sep 2015, 01:47
Has thanked: 5 times
Been thanked: 15 times

Re: v7: Need new premium license? [EDIT2: had to update Java, working now]

Unread post by garyo » 17 May 2019, 17:03

I created a whole new Freenas jail with a more recent FreeBSD, installed latest Java (openjdk 12) and Madsonic 7, copied over my database from backup, and now my Premium license works again. Thanks!
These users thanked the author garyo for the post:
Madsonic

Post Reply