Failed to index songs/albums with non-US characters

Post your Server Bug Report
VikingOy
Posts: 38
Joined: 03 May 2015, 20:26
Has thanked: 3 times
Been thanked: 7 times

Failed to index songs/albums with non-US characters

Unread post by VikingOy » 30 Apr 2019, 14:10

Hi All,

I noticed that Madsonic fails to index files with foreign characters.
Is there a way to set locale to UTF-8 or similar?

Viking
These users thanked the author VikingOy for the post:
Madsonic

KaeTuuN
Posts: 40
Joined: 09 Feb 2015, 23:30
Has thanked: 5 times
Been thanked: 17 times

Re: Failed to index songs/albums with non-US characters

Unread post by KaeTuuN » 08 May 2019, 09:54

Can you specify the Problem?
1. Use this Header: viewtopic.php?f=2&t=1520
2. What type of Files? MP3? Flac? ogg? avi? mkv?
3. Did you mean the Filenames or Informations like ID3-Tags?
4. Which Characters are problematic?
5. Can you see anything in the logfiles?

I have lots of Files with Ä, Ö, Ü, ä, ö, ü and they work without any Problem.


Greetings Kae
These users thanked the author KaeTuuN for the post:
Madsonic

VikingOy
Posts: 38
Joined: 03 May 2015, 20:26
Has thanked: 3 times
Been thanked: 7 times

Re: Failed to index songs/albums with non-US characters

Unread post by VikingOy » 07 Jun 2019, 13:55

There are plenty of posts in this forum with similar topic. Noone seems to know how to tell Madsonic to use UTF-8.
If you have made this working, you are the only one. I'm sure the community would love to have an explanation.

2. In my case, I only use MP3 files
3. Albums and songs containing any special character(s) - filename or tag, is just ignored by Madsonic.
4. All non-ASCII characters. Umlauts, accents, special characters like the Scandinavian Æ, Ø and Å etc. etc.
5. Nothing in the logs about what has been skipped (ignored), nor why.

Please help.
These users thanked the author VikingOy for the post:
Madsonic

User avatar
Matt Zornig
Contributor
Contributor
Posts: 241
Joined: 14 Feb 2017, 12:03
Has thanked: 38 times
Been thanked: 28 times

Re: Failed to index songs/albums with non-US characters

Unread post by Matt Zornig » 09 Jul 2019, 15:30

VikingOy wrote:
07 Jun 2019, 13:55
There are plenty of posts in this forum with similar topic. Noone seems to know how to tell Madsonic to use UTF-8.
If you have made this working, you are the only one.
Its working here for me too, so we are two users now ;-D

Ok, all joking aside,
there is no UTF-8 setting, AFAIK, because it works out of the box.

Obviously, not for your box, so tell us about your box, use the support header, KaeTuuN mentionend in 1)

Also, please take screenshots from your files, and how it looks like in MadSonic.


So, if your explorer (or whatever filecommander on whatever system you use) shows something like

C:\music\mp3\album\song.mp3
C:\music\mp3\album with Æ, Ø and Å etc\song with Æ, Ø and Å etc.mp3

in MadSonic, you just see what?

Check my screenshots and help us, helping you.
2019-07-09 16-25-19_Total Commander (x64) 9.22a.png
2019-07-09 16-18-35_Aciddicted - Acid Junkies - Madsonic - Waterfox (Private Browsing).png
2019-07-09 16-18-10_Aciddicted - Acid Junkies - Madsonic - Waterfox (Private Browsing).png

Post Reply