Page 1 of 1

At my wits end trying to get Madsonic to recognise my files

Posted: 10 Jan 2018, 11:09
by andyfitter
Currently running Adopter build 6.3.9840.8df1ddd.20180107.0710 on my Synology.

I am having endless problems getting Madsonic to recognise my files, a mixture of MP3, ALAC and M4A.

It worked, once, but now whatever I do I see one of a combination of errors.

If I enter the full path to where they are located in the 'Media Folders' section, I see 'folder not found'. This is path as simple as '/volume2/music/Artists'. If I enter the next level up, such as '/volume2/music', it accepts it OK, but then doesn't manage to find any files at all. I know it is a valid path, it is copied and pasted fro a terminal window.

I often see similar to this in the logs:

WARN FileUtil - Failed to list children for /volume2/music

If I point it to one level higher still ' /volume2', it finds all the files, but also finds every file hanging off of that mount point, containing about 10 other sub folders. It appears that Madsonic is almost expecting a certain folder structure, and if it doesn't find it, it just sits there giving errors. I'm yet to figure out what the magic is though.

I've tried removing the database and letting it recreate it. I've tried moving directories around, I've tried changing all the permissions so everybody in the world can read everything, but still it is so unpredictable. I've seen other posts on here going back a few years, with similar problems. Surely there is a solution by now?

It did work once. Stupidly, I wanted to reorganise my music and deleted the folder and moved it somewhere else. It has never worked since.

I really, really want to like Madsonic, but I'm finding it so difficult when things like this are so difficult. I tried it once before, a year or two ago, and hit similar issues and gave up. I was really hoping they were resolved.


Re: At my wits end trying to get Madsonic to recognise my fi

Posted: 10 Jan 2018, 21:24
by Madsonic
Hi there,

here are some screenshots of the latest test installation on a Synology 3615 with DSM 6.1.4 and Madsonic 6.3.9840 installed.

* Check on the about page, if you have a working ffmpeg version (version in green is ok | error message in red)!
* Don't forget to set the permission on you media folder for the madsonic service account!
best regards,
The Madsonic Team

Re: At my wits end trying to get Madsonic to recognise my fi

Posted: 13 Jan 2018, 11:47
by andyfitter
Thanks for getting back to me and offering your recommendations!

I can only put my hands up at this point and say it was my fault! I'd been staring at it for so long I was blind to a few problems. I'll outline what I did and what went wrong, in case it helps somebody in the future.

I had working install of Madsonic on my Synology, and decide to update to the latest bleeding edge version. I uninstalled, and then reinstalled the new version. As some background info, I also had a parallel working install of Subsonic, which was stopped, for comparison purposes.

I assumed at this point all should be ok - just point it back to my Media folders etc. However, I ended up with all the problems outlined above.

I stared at permissions and paths endlessly... However it hadn't occurred to me that uninstalling Subsonic would remove the created Subsonic user, and thus remove the permissions for my music share.

When I reinstalled, the new Madsonic user was created, but the permissions weren't put back, which makes perfect sense now looking back.

As much as I stared at the folder permissions it all looked ok. What was actually the case was the the Subsonic user still had permissions, but the newly created Madsonic user didn't. And I was blind to that, no matter how long I stared. It took the support email above and a few days away, to go revisit again and it was staring me in the face. I fixed the permissions for the Madsonic user and all was fine.

Maybe it might be useful if instead of generically giving the 'folder not found', under those circumstances it could give a more useful error, such as permissions error, if it is possible to detect that?

Thanks again for your help, I'll be sticking with Madsonic!