WARNING no transcoder found!

Need help? Post your questions here.
KaeTuuN
Posts: 15
Joined: 09 Feb 2015, 23:30
Has thanked: 2 times
Been thanked: 3 times

WARNING no transcoder found!

Unread post by KaeTuuN » 10 Mar 2017, 11:27

Code: Select all

=========================================================================================
 VERSION:      MADSONIC 6.2 | BUILD: 9040
 SERVLET:      TOMCAT 8
 SERVER:       CPU: Core i3-6100 | ARCH: X64 | MEMORY: 16GB | HDD: 6TB + 3TB | SSD: 128GB | 
 OS:           Linux Mint 18.1 including Debian like hardening
 SYSTEM:       SERVER
 INSTALLER:    WAR File
 JAVA:         ORACLE JDK 1.8
 BROWSER:      does not matter
 CLIENT:       does not matter
 DESCRIPTION:  "WARNING no transcoder found!" - Fresh Installation via "WAR-File" and the "/var/madsonic/transcode" Directory doesn't even Exist
 REPRODUCIBLE: YES
=========================================================================================
So, how do I manually configure a transcoder?
What are the Standard entries?
The "ffmpeg" package from Distri Source is installed.

Mfg Kae

User avatar
Matt Zornig
Contributor
Contributor
Posts: 230
Joined: 14 Feb 2017, 12:03
Has thanked: 34 times
Been thanked: 21 times

Re: WARNING no transcoder found!

Unread post by Matt Zornig » 11 Mar 2017, 04:02

maybe you need to put the ffmpeg into the path?
can you reach it on the console, just typing ffmpeg --help in your home-directory?

this is what my settings look like:
transcoding.png
check: transcode path

Downsample command

Code: Select all

ffmpeg -i %s -map 0:a:0 -b:a %bk -ar 44100 -v 0 -f mp3 -
HTTP Live Streaming command

Code: Select all

ffmpeg -ss %o -t %d -i %s -s %wx%h -v 0 -b:v %bk -maxrate %bk -bufsize 256k -flags -global_header -map 0:v:0 -map 0:%k -ac 2 -f mpegts -c:v libx264 -preset superfast -c:a aac -b:a 96k -strict -2 -threads 0 -copyts -
Dynamic Adaptive Streaming command

Code: Select all

ffmpeg -ss %o -t %d -i %s -async 1 -b:v %bk -s %wx%h -ar 44100 -ac 2 -v 0 -f webm -c:v vp8 -preset superfast -c:a libmp3lame -threads 0 -

audio->mp3:

Code: Select all

ffmpeg -i %s -map 0:a:0 -b:a %bk -v 0 -f mp3 -
These users thanked the author Matt Zornig for the post:
KaeTuuN

KaeTuuN
Posts: 15
Joined: 09 Feb 2015, 23:30
Has thanked: 2 times
Been thanked: 3 times

Re: WARNING no transcoder found!

Unread post by KaeTuuN » 18 Mar 2017, 12:37

Thanks for the help! I had the wrong transcode path...
Changed it and everything is ok. :)

Greetings Kae
These users thanked the author KaeTuuN for the post:
Madsonic

eevv
Posts: 5
Joined: 20 Jun 2015, 19:04
Has thanked: 2 times
Been thanked: 6 times

Re: WARNING no transcoder found!

Unread post by eevv » 24 Mar 2017, 06:21

On one Synology NAS I have Subsonic, installed using the ffmpeg version of Synology Serviio, supposedly. But in the log I can see that it is somehow "access denied" to ffmpeg, so if it's eg a FLAC it will just play the file without transcoding to mp3 or whatever. Which is fine but no good in the long run if playing from mobile with data quota.

Could I conceivably fix this simply by copying and pasting your commands as listed here ?

If that breaks something, is there a specific config file or something to delete to reset transcoding settings to what they were when package installed ? Or would I then also lose the whole database etc. too ?


Thanks :)

Matt Zornig wrote:maybe you need to put the ffmpeg into the path?
can you reach it on the console, just typing ffmpeg --help in your home-directory?

this is what my settings look like:
transcoding.png
check: transcode path

Downsample command

Code: Select all

ffmpeg -i %s -map 0:a:0 -b:a %bk -ar 44100 -v 0 -f mp3 -
HTTP Live Streaming command

Code: Select all

ffmpeg -ss %o -t %d -i %s -s %wx%h -v 0 -b:v %bk -maxrate %bk -bufsize 256k -flags -global_header -map 0:v:0 -map 0:%k -ac 2 -f mpegts -c:v libx264 -preset superfast -c:a aac -b:a 96k -strict -2 -threads 0 -copyts -
Dynamic Adaptive Streaming command

Code: Select all

ffmpeg -ss %o -t %d -i %s -async 1 -b:v %bk -s %wx%h -ar 44100 -ac 2 -v 0 -f webm -c:v vp8 -preset superfast -c:a libmp3lame -threads 0 -

audio->mp3:

Code: Select all

ffmpeg -i %s -map 0:a:0 -b:a %bk -v 0 -f mp3 -

Post Reply