6.1 8150(also 8220) madsonic-agent never turn to green. :(

Need help? Post your questions here.
fumiman
Posts: 27
Joined: 11 May 2013, 08:42
Has thanked: 5 times
Been thanked: 4 times

6.1 8150(also 8220) madsonic-agent never turn to green. :(

Unread post by fumiman »

Hello.

I could use madsonic server with same setting yesterday.
But today I restarted windows, madsonic-agent icon could not turn to green.
service status is "Running. Auto-start"
so I can not open madsonic within browser. :(

I tried restarting windows, re-installing newest Java, reboot madsonic-agent, but it never turn to green.

can anyone tell me how to solve this?

thanks.

=========================================================================================
VERSION: MADSONIC 6.1 | BUILD: 8150
SERVLET: -
SERVER: CPU: Cherry-Trail Z8300 | ARCH: X64 | MEMORY: 4GB | HDD: 64GB
OS: WINDOWS 10
SYSTEM: SERVER
INSTALLER: WINDOWS
JAVA: ORACLE JDK 1.8
BROWSER: CHROME 49
CLIENT: MADSONIC 5.7
DESCRIPTION: -
REPRODUCIBLE: YES | NO
=========================================================================================
Last edited by fumiman on 26 Apr 2016, 10:10, edited 1 time in total.

gurutech
Contributor
Contributor
Posts: 323
Joined: 02 Jan 2013, 04:56
Has thanked: 11 times
Been thanked: 105 times

Re: 6.1 8150 madsonic-agent never turn to green. :(

Unread post by gurutech »

Try going to your Madsonic server's website, and see if you just get a 404 (page not found) or something else like a database error. I had the database error, so I had to delete the Madsonic folder from C:\ and reinstall it.

If you try reinstalling Madsonic without deleting this folder, you won't lose any settings.
These users thanked the author gurutech for the post:
fumiman
Rating: 7.69%

fumiman
Posts: 27
Joined: 11 May 2013, 08:42
Has thanked: 5 times
Been thanked: 4 times

Re: 6.1 8150 madsonic-agent never turn to green. :(

Unread post by fumiman »

thanks for reply.

Web page tell me "Connection refused"
maybe then madsonic icon is green, I can open madsonic web page..


anyway, I will try to re-install madsonic again with overwrite.
if it can not fix, I should decide clean install :(

fumiman
Posts: 27
Joined: 11 May 2013, 08:42
Has thanked: 5 times
Been thanked: 4 times

Re: 6.1 8150 madsonic-agent never turn to green. :(

Unread post by fumiman »

re-installing fix this problem.
But Logon information@Service has disappeared.
http://beta.madsonic.org/pages/getting-started.jsp#2

Im using NAS on madsonic.
so I must fill this information in for using NAS.
so, I filled acc information in again.
but madsonic can not turn to green again. :|
switching to Local system acc can turn madsonic to green, but it can not find NAS :(

hmm...

sorry for my bad English.

fumiman
Posts: 27
Joined: 11 May 2013, 08:42
Has thanked: 5 times
Been thanked: 4 times

Re: 6.1 8150 madsonic-agent never turn to green. :(

Unread post by fumiman »

For the moment, I updated to Windows 10 insider preview.
and it fixed...I can use madsonic with no problem now. :?

gurutech
Contributor
Contributor
Posts: 323
Joined: 02 Jan 2013, 04:56
Has thanked: 11 times
Been thanked: 105 times

Re: 6.1 8150 madsonic-agent never turn to green. :(

Unread post by gurutech »

You will need to make sure the account you use for the login has proper (read/write) permissions to your NAS share.
These users thanked the author gurutech for the post (total 2):
fumimanMadsonic
Rating: 15.38%

fumiman
Posts: 27
Joined: 11 May 2013, 08:42
Has thanked: 5 times
Been thanked: 4 times

Re: 6.1 8150 madsonic-agent never turn to green. :(

Unread post by fumiman »

I already set suitably permission :(

anyway, it was fixed :D :thumbsup:
These users thanked the author fumiman for the post:
Madsonic
Rating: 7.69%

fumiman
Posts: 27
Joined: 11 May 2013, 08:42
Has thanked: 5 times
Been thanked: 4 times

Re: 6.1 8150 madsonic-agent never turn to green. :(

Unread post by fumiman »

hi

same problem again :oops:
Attachments
for using nas, entered id/pass @ service. but madsonic never turn to green.
for using nas, entered id/pass @ service. but madsonic never turn to green.

fumiman
Posts: 27
Joined: 11 May 2013, 08:42
Has thanked: 5 times
Been thanked: 4 times

Re: 6.1 8150 madsonic-agent never turn to green. :(

Unread post by fumiman »

switch to "local system account", madsonic turn to green.
but nas can not see in madsonic...
Attachments
switch to &quot;local system account&quot;, madsonic turn to green.<br />but nas can not see in madsonic...
switch to "local system account", madsonic turn to green.
but nas can not see in madsonic...

fumiman
Posts: 27
Joined: 11 May 2013, 08:42
Has thanked: 5 times
Been thanked: 4 times

Re: 6.1 8150 madsonic-agent never turn to green. :(

Unread post by fumiman »

server log is here.

[2016-04-25 09:35:29,264] WARN HsqlDaoHelper - Checking database schema ...
[2016-04-25 09:35:33,754] INFO HsqlDaoHelper - Done checking database schema.
[2016-04-25 09:35:33,756] INFO HsqlDaoHelper - Checking HSQLDB version: 2.3.3
[2016-04-25 09:35:35,103] INFO SettingsService - Java: 1.8.0_77, OS: Windows 10
[2016-04-25 09:35:35,119] INFO SettingsService - write transcode path to property file.
[2016-04-25 09:35:35,292] INFO SettingsService - ffmpeg: ffmpeg version N-79253-g8005b6d (06.04.2016) Copyright (c) 2000-2016 the FFmpeg developers
Attachments
nas can not see with local system account
nas can not see with local system account

gurutech
Contributor
Contributor
Posts: 323
Joined: 02 Jan 2013, 04:56
Has thanked: 11 times
Been thanked: 105 times

Re: 6.1 8150(also 8220) madsonic-agent never turn to green.

Unread post by gurutech »

You can keep the folder structure the same, but only use one folder share to the parent folder.

For example, use: \\nas\share\Music instead of \\nas\share\Music\A, \\nas\share\Music\B, etc....

Then make sure that your NAS permissions for the "share" folder are set to allow the name you are setting to replace the local system account.
These users thanked the author gurutech for the post:
fumiman
Rating: 7.69%

fumiman
Posts: 27
Joined: 11 May 2013, 08:42
Has thanked: 5 times
Been thanked: 4 times

Re: 6.1 8150(also 8220) madsonic-agent never turn to green.

Unread post by fumiman »

sorry for response late.

ok. I will try it! :D

raidflex
Posts: 15
Joined: 29 Apr 2013, 21:47
Has thanked: 0
Been thanked: 6 times

Re: 6.1 8150(also 8220) madsonic-agent never turn to green.

Unread post by raidflex »

So I believe I may have the same problem. Currently I have Madsonic running on a Freenas system in a jail. In the past I was able to just overwrite the "madsonic-booter.jar" and "madsonic.war" files in order to update to the latest beta version. After moving to version 6.1.8280 the Madsonic service refuses to start. If I revert back to 6.1.8190 then Madsonic loads properly.

I have tried deleting the db even and it still refuses to start. The logs do not have any info or errors.

fumiman
Posts: 27
Joined: 11 May 2013, 08:42
Has thanked: 5 times
Been thanked: 4 times

Re: 6.1 8150(also 8220) madsonic-agent never turn to green.

Unread post by fumiman »

finally I prepared the structure including "share" folder.
in the beginning, it activated normally (it could turn to green)

but now, same problem has occurred again :(

oh my.... I can not help but use fuckin temporary Google's Play Music again :(((((((

fumiman
Posts: 27
Joined: 11 May 2013, 08:42
Has thanked: 5 times
Been thanked: 4 times

Re: 6.1 8150(also 8220) madsonic-agent never turn to green.

Unread post by fumiman »

I think to give up using nas. and I buy 2.5inch usb HDD for music... :|

fumiman
Posts: 27
Joined: 11 May 2013, 08:42
Has thanked: 5 times
Been thanked: 4 times

Re: 6.1 8280 madsonic-agent never turn to green. :(

Unread post by fumiman »

same bug occur with USB HDD again... :|
Attachments
プレゼンテーション1.jpg

gurutech
Contributor
Contributor
Posts: 323
Joined: 02 Jan 2013, 04:56
Has thanked: 11 times
Been thanked: 105 times

Re: 6.1 8150(also 8220) madsonic-agent never turn to green.

Unread post by gurutech »

For the NAS issue, have you tried mapping a drive to your Windows PC? (ie, make M: your music drive mapped to \\NAS\Share\Music ) and then enter the M:\ path as your media folders?

fumiman
Posts: 27
Joined: 11 May 2013, 08:42
Has thanked: 5 times
Been thanked: 4 times

Re: 6.1 8150(also 8220) madsonic-agent never turn to green.

Unread post by fumiman »

gurutech wrote:For the NAS issue, have you tried mapping a drive to your Windows PC? (ie, make M: your music drive mapped to \\NAS\Share\Music ) and then enter the M:\ path as your media folders?

Hi gurutech.

I understood it is not NAS issue.
and I already mapped my NAS to "z drive".

maybe this is DB issue I think...

gurutech
Contributor
Contributor
Posts: 323
Joined: 02 Jan 2013, 04:56
Has thanked: 11 times
Been thanked: 105 times

Re: 6.1 8150(also 8220) madsonic-agent never turn to green.

Unread post by gurutech »

To verify it's a db issue, you will need to completely uninstall Madsonic, then manually remove (or at least rename) your C:\Madsonic folder, reboot, and then reinstall from scratch.

You'll lose info like usernames, and anything else stored in the db, but it should work. I had to do this when I upgraded to 6.1 on my windows PC.

fumiman
Posts: 27
Joined: 11 May 2013, 08:42
Has thanked: 5 times
Been thanked: 4 times

Re: 6.1 8150(also 8220) madsonic-agent never turn to green.

Unread post by fumiman »

Hi.

I gave up to use with 6.1.
I just know this bug occur with 6.1 only.
and tried 5.X and 6.0 server.

now, server is all time green with 6.0 server.
I wanna use madsonic 6.1 in the future. :D

Post Reply