New music not showing up.

Need help? Post your questions here.
slyr114
Posts: 2
Joined: 02 Aug 2015, 23:50
Has thanked: 0
Been thanked: 0

New music not showing up.

Unread post by slyr114 »

After my initial media scan upon first time setup, nothing I add to my music folder is being after via a normal scan. I have my music organized by Letter, then artist, then album. I had an old fork of subsonic called Musiccabinet that had no issues at all scanning my new files, even in this folder structure but for some reason madsonic just does not add files as it should. How can I fix this?

dreagan
Posts: 18
Joined: 02 Dec 2015, 19:25
Has thanked: 0
Been thanked: 5 times

Re: New music not showing up.

Unread post by dreagan »

I have the exact same issue. The initial scan took in my entire music collection of about 450G of data. Not a hitch. I have about 7 folders specified and they loaded correctly the first time I added them.
I have all of my folders set to rescan every 12 hours and these scans have always run, I can see that in the logs. But none of the new music gets added to Madsonic. I have tried to trigger the rescan all folder functionality, which I guess does the same as the separate folder scans, but all without result.
When I do a full rescan however, the new music is added (I got something else funky going on here, but I'll try to stay on topic and first resolve this issue).

I'm running madsonic on a Windows 7 Intel Nuc and my music resides on an external harddrive that is connected most of the time.

dreagan
Posts: 18
Joined: 02 Dec 2015, 19:25
Has thanked: 0
Been thanked: 5 times

Re: New music not showing up.

Unread post by dreagan »

My planned scan tasks are also not running it seems. When I set a new date/time they run once at that time, but the next scheduled time is skipped and after that no runs take place anymore.
I just installed the latest 6 release, but it still isn't fixed. I had noticed that the normal rescan was broken for me, it threw an error, somehow it was missing a folder to back up my playlists. After I created my playlists backup folder the normal rescan worked again and I hoped that was the end of it. But a normal rescan still won't add my new folders / files.

Is there nobody else here with this kind of problem?
Could it be because of the external hard drive the music is stored on?

gr8pa2
Posts: 15
Joined: 14 Jan 2014, 15:00
Has thanked: 0
Been thanked: 5 times

Re: New music not showing up.

Unread post by gr8pa2 »

Got the same issue on ubuntu 14.04. My initila scan after install of Madsonic 6.1.8150 took a long time. But since, not all my new music are showing up. Checked for permissions issue, its really weird.

gr8pa2
Posts: 15
Joined: 14 Jan 2014, 15:00
Has thanked: 0
Been thanked: 5 times

Re: New music not showing up.

Unread post by gr8pa2 »

Found some details about this issue. My library folder structure is set up Artist/Album/Music Files. When I add a new Artist folder, the Normal Scan will find it and add it to the database, but if the music is in an existing Artist folder, then I need to do a Full Rescan for Madsonic to add the album to the database.

When new Albums are added to the Artist folder, the Artist folder modification date is not changed. Maybe an issue with my music importer "Beets".
These users thanked the author gr8pa2 for the post:
Madsonic
Rating: 7.69%

Oxize
Posts: 38
Joined: 23 Jan 2016, 15:31
Has thanked: 1 time
Been thanked: 7 times

Re: New music not showing up.

Unread post by Oxize »

There was another topic about this in Support 6.x about not adding new music to madsonic. Since Synology rolled out DSM 6, which needed a upgraded madsonic version (linux), mad-devil mad us a new one with Madsonic 6.1. I had also problems with linking my old music directory to the new madsonic install. Only when i made a new share on my NAS and make that entry into madsonic, it was importing everything again. I have like 80GB of music. All music is so far importing from the new share. Checked permissions? Tried with a new share as test?

frank2228
Posts: 33
Joined: 23 Jul 2014, 00:59
Has thanked: 32 times
Been thanked: 11 times

Re: New music not showing up.

Unread post by frank2228 »

I had the same issue but the newest versions of server 6.x seems to have fixed the issue. I have tried both beta and stable releases.

Post Reply