Script to run War upgrade in the new Madsonic

Frequently asked questions. Tutorials, tips and tricks.
chali
Contributor
Contributor
Posts: 100
Joined: 13 Dec 2012, 16:25
Has thanked: 18 times
Been thanked: 35 times

Script to run War upgrade in the new Madsonic

Unread post by chali » 21 Sep 2013, 00:03

Hi

This script is made by Marty, i have only made a small edit so it will work with the new Madsonic


Remember to run it as root and to use big letters (Y/N) when you answer the questions in the console,
When it asking for the built number it the last 4 numbers ( example 3660)

/Sincerely Chali
Attachments
madsonicupdate.sh
Masonic War update script
(2.76 KiB) Downloaded 260 times
These users thanked the author chali for the post:
Madsonic

nodename
Posts: 2
Joined: 13 Aug 2017, 02:06
Has thanked: 0
Been thanked: 0

Re: Script to run War upgrade in the new Madsonic

Unread post by nodename » 13 Aug 2017, 02:12

Hi,
Can I use this script to upgrade from 5.x to 6.x? And will the Android client need to be changed as well?
Thanks!

User avatar
Madsonic
Administrator
Administrator
Posts: 943
Joined: 07 Dec 2012, 03:58
Has thanked: 1124 times
Been thanked: 434 times

Re: Script to run War upgrade in the new Madsonic

Unread post by Madsonic » 13 Aug 2017, 11:19

Hi there,

This script is only for upgrading the server installation.

We working on a new transfer tool to migrate old data to the new Madsonic 6.3 database.

https://gist.github.com/MadMarty/2ed7f5 ... 04e19e4749

Stay tuned! ;)

Best regards,
The Madsonic Team

nodename
Posts: 2
Joined: 13 Aug 2017, 02:06
Has thanked: 0
Been thanked: 0

Re: Script to run War upgrade in the new Madsonic

Unread post by nodename » 15 Aug 2017, 00:02

Yes, I understand it's for the server. That's what the first part of my question referred to.
Can I use the script to upgrade the server from 5.x to 6.x?
What is the implication of your comment about migrating the data? Is upgrading the server with the script not sufficient?
Also is the current release of the Android client compatible with 6.x?

Post Reply