[Solved] OSX Java

Mission accomplished!
skopo
Contributor
Contributor
Posts: 68
Joined: 07 Apr 2013, 07:48
Has thanked: 8 times
Been thanked: 16 times

[Solved] OSX Java

Unread post by skopo » 18 Sep 2015, 13:11

Hello

Does madsonic-6.0.7460 still run Java6 only on OS X?
These users thanked the author skopo for the post:
Madsonic

User avatar
Madsonic
Administrator
Administrator
Posts: 961
Joined: 07 Dec 2012, 03:58
Has thanked: 1150 times
Been thanked: 450 times

Re: OSX Java

Unread post by Madsonic » 18 Sep 2015, 14:55

Hi there,

Java 6 is more as outdated ;)

at least you must upgrade to Java7

EOL INFO: http://www.oracle.com/technetwork/java/ ... 35779.html

DOWNLOAD: http://www.oracle.com/technetwork/java/ ... 33155.html

best regards

skopo
Contributor
Contributor
Posts: 68
Joined: 07 Apr 2013, 07:48
Has thanked: 8 times
Been thanked: 16 times

Re: OSX Java

Unread post by skopo » 18 Sep 2015, 15:15

Madevil wrote:Hi there,

Java 6 is more as outdated ;)

at least you must upgrade to Java7

EOL INFO: http://www.oracle.com/technetwork/java/ ... 35779.html

DOWNLOAD: http://www.oracle.com/technetwork/java/ ... 33155.html

best regards
Fantastic

I installed Madsonic 6.0.7460 (native mac) to my test server OSX 10.10.5 with JRE8 and Madsonic doesn't start. No window, no serice nothing just nothing.
How to troubleshoot?

User avatar
Madsonic
Administrator
Administrator
Posts: 961
Joined: 07 Dec 2012, 03:58
Has thanked: 1150 times
Been thanked: 450 times

Re: OSX Java

Unread post by Madsonic » 18 Sep 2015, 15:56

hi there,

if have recheck the installation with OSX 10.8.5 & JDK 1.8 and worked as aspected.

For troubleshooting look at the installation guides

http://beta.madsonic.org/pages/installation.jsp#mac
http://beta.madsonic.org/pages/installation.jsp#java

TYI: if you previously use Madsonic 5.1 on this MAC you have to cleanup this folder bellow before you start Madsonic 6.0

Code: Select all

/Library/Application Support/Madsonic
best regards

skopo
Contributor
Contributor
Posts: 68
Joined: 07 Apr 2013, 07:48
Has thanked: 8 times
Been thanked: 16 times

Re: OSX Java

Unread post by skopo » 19 Sep 2015, 07:36

Yes!

Code: Select all

/Library/Application Support/Madsonic
Totally forget to clean this folder. Now works.
These users thanked the author skopo for the post:
Madsonic

skopo
Contributor
Contributor
Posts: 68
Joined: 07 Apr 2013, 07:48
Has thanked: 8 times
Been thanked: 16 times

Re: OSX Java

Unread post by skopo » 21 Sep 2015, 12:20

Something is still wrong...

OSX versio is 10.10.5 and Java JRE is 1.8.0.60

UniversalJavaApplicationStub returns:

Code: Select all

Applications/Madsonic.app/Contents/MacOS/universalJavaApplicationStub ; exit;
Exception in thread "main" java.lang.UnsupportedClassVersionError: org/madsonic/booter/Main : Unsupported major.minor version 51.0
	at java.lang.ClassLoader.defineClass1(Native Method)
	at java.lang.ClassLoader.defineClassCond(ClassLoader.java:637)
	at java.lang.ClassLoader.defineClass(ClassLoader.java:621)
	at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:141)
	at java.net.URLClassLoader.defineClass(URLClassLoader.java:283)
	at java.net.URLClassLoader.access$000(URLClassLoader.java:58)
	at java.net.URLClassLoader$1.run(URLClassLoader.java:197)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
	at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
logout

[Process completed]
And Java -version shows:

Code: Select all

java version "1.8.0_60"
Java(TM) SE Runtime Environment (build 1.8.0_60-b27)
Java HotSpot(TM) 64-Bit Server VM (build 25.60-b23, mixed mode)
No window, no service, nothing...

User avatar
Madsonic
Administrator
Administrator
Posts: 961
Joined: 07 Dec 2012, 03:58
Has thanked: 1150 times
Been thanked: 450 times

Re: [Solved] OSX Java

Unread post by Madsonic » 21 Sep 2015, 13:54

Hi there,

The error message means that you are using an older JAVA version,
i guess this is because your $JAVA_HOME environment isn't set right.

to check:

Code: Select all

$ echo $JAVA_HOME
expected output:

Code: Select all

/Library/Java/JavaVirtualMachines/jdk1.8.0_60.jdk/Contents/Home
to set this variable: In Mac OSX 10.5 or later, Apple recommends to set the $JAVA_HOME variable to /usr/libexec/java_home

Code: Select all

nano .bash_profile 

export JAVA_HOME=$(/usr/libexec/java_home)

source .bash_profile

echo $JAVA_HOME
/Library/Java/JavaVirtualMachines/jdk1.8.0_60.jdk/Contents/Home
or

Code: Select all

echo export JAVA_HOME=$(/usr/libexec/java_home) > .bash_profile
https://support.apple.com/kb/dl1572?loc ... cale=de_DE

http://www.oracle.com/technetwork/java/ ... 33151.html

Hope this help you. :)

Best regards

Post Reply