Web Player Not Working

Post your Server Bug Report
Posts: 1
Joined: 01 May 2015, 03:42
Has thanked: 0
Been thanked: 0

Web Player Not Working

Unread post by soldier9599 »

I just installed Madsonic today and everything is working great except the web player. I'm able to stream music and video to my phone just fine, but the web player does not work from either the server PC or my laptop connecting over the web. The web player played music just fine right when it was a brand new installation but now something is different. Also video never worked in the web player. At first it just brought up a black rectangle, but now trying to play a video gives an error. I was going to put the entire error in here but the forum is telling me that it thinks it's spam so it won't let me post it. It's a MalformedURLException java error.

I'm not getting any errors when the music doesn't play and the log isn't showing anything about it. I tried restarting the service, rebooting, and reinstalling Madsonic. I've tried this in Chromium, Firefox, and Midori. None of it makes any difference. When I try to play music it just behaves as if I didn't even click on the button. Downloading anything works just fine in the web browser, and I can click "share" to get a share link then visit that url and it plays fine in the web browser. I was going to try the share trick with video but strangely there is no share link for videos. I cannot add anything to queue but I can make playlists. Playlists do not play either. If I change the player settings to play in my media player and try to play, it only downloads something when I hit the big play button for the queue (which won't accept any songs). So then I download the m3u file and media player recognizes the file but doesn't actually play anything. It just says "stopped."

User avatar
Posts: 211
Joined: 25 Feb 2014, 14:41
Has thanked: 40 times
Been thanked: 65 times

Re: Web Player Not Working

Unread post by DoCC »

mmh strange;
the fact that the share link works makes me frown ...

the guest user has some default player / encoding settings ...
have you tried to adapt your player settings to the guest account ?
in most cases some wierd transcoding settings are the reason for "not playing anything"


Post Reply