Playlist Loading Time

Need help? Post your questions here.
bcrivers
Posts: 33
Joined: 13 Jan 2013, 16:28
Has thanked: 2 times
Been thanked: 9 times

Playlist Loading Time

Unread post by bcrivers »

I am experiencing slow delays when opening Playlists? Is this normal?

DrAlban
Posts: 14
Joined: 28 Dec 2012, 23:53
Has thanked: 17 times
Been thanked: 0

Re: Playlist Loading Time

Unread post by DrAlban »

bcrivers wrote:I am experiencing slow delays when opening Playlists? Is this normal?

If I load a playlist, doing it on the server, not using Network, it takes about 20secs.
Meaning ->select the playlist, containing 462 songs, in left frame -> it loads into main window -> Push "play all" -> The first starts playing = about 20 secs.
I got an SSD as systemdisk and all the songs are located on a second S-ATA HDD...

Don´t know if this helps you ,but maybe you got some kind of hint if you´re having a long loading time...

bcrivers
Posts: 33
Joined: 13 Jan 2013, 16:28
Has thanked: 2 times
Been thanked: 9 times

Re: Playlist Loading Time

Unread post by bcrivers »

Knowing what others experience helps. I guess an initial load time is normal behavior. My playlist of 600 songs takes about 1 minute to load.

GJ51
Contributor
Contributor
Posts: 192
Joined: 15 Dec 2012, 17:52
Has thanked: 42 times
Been thanked: 83 times

Re: Playlist Loading Time

Unread post by GJ51 »

DrAlban wrote:
bcrivers wrote:I am experiencing slow delays when opening Playlists? Is this normal?

If I load a playlist, doing it on the server, not using Network, it takes about 20secs.
Meaning ->select the playlist, containing 462 songs, in left frame -> it loads into main window -> Push "play all" -> The first starts playing = about 20 secs.
I got an SSD as systemdisk and all the songs are located on a second S-ATA HDD...

Don´t know if this helps you ,but maybe you got some kind of hint if you´re having a long loading time...

Interesting ... are the playlists stored on the SSD or the HD? Have you tried both ways? Performance difference?

DrAlban
Posts: 14
Joined: 28 Dec 2012, 23:53
Has thanked: 17 times
Been thanked: 0

Re: Playlist Loading Time

Unread post by DrAlban »

GJ51 wrote:
DrAlban wrote:
bcrivers wrote:I am experiencing slow delays when opening Playlists? Is this normal?

If I load a playlist, doing it on the server, not using Network, it takes about 20secs.
Meaning ->select the playlist, containing 462 songs, in left frame -> it loads into main window -> Push "play all" -> The first starts playing = about 20 secs.
I got an SSD as systemdisk and all the songs are located on a second S-ATA HDD...

Don´t know if this helps you ,but maybe you got some kind of hint if you´re having a long loading time...

Interesting ... are the playlists stored on the SSD or the HD? Have you tried both ways? Performance difference?


To be honest, don't know where the playlist is stored... Where is it by default?

GJ51
Contributor
Contributor
Posts: 192
Joined: 15 Dec 2012, 17:52
Has thanked: 42 times
Been thanked: 83 times

Re: Playlist Loading Time

Unread post by GJ51 »

That's a good question as well ...

In Settings/General you can define the import ans export directories, the defaults are c:\music\Incoming and c:\playlists-export, which leads me to suspect that the actual lists used by the program are probably stored in the database.

If I'm right on that, then the time it takes to compile a playlist is probably CPU dependent - just guessing. Marty would have to confirm if my guess is correct.

DrAlban
Posts: 14
Joined: 28 Dec 2012, 23:53
Has thanked: 17 times
Been thanked: 0

Re: Playlist Loading Time

Unread post by DrAlban »

GJ51 wrote:That's a good question as well ...

In Settings/General you can define the import ans export directories, the defaults are c:\music\Incoming and c:\playlists-export, which leads me to suspect that the actual lists used by the program are probably stored in the database.

If I'm right on that, then the time it takes to compile a playlist is probably CPU dependent - just guessing. Marty would have to confirm if my guess is correct.
Yes, I think your're right, it is in the DB. Tried to search for the playlist name on both SSD and HDD, but since I've not exported it, the search returns nothing...

Skinjob
Posts: 35
Joined: 13 Jan 2013, 23:20
Has thanked: 2 times
Been thanked: 9 times

Re: Playlist Loading Time

Unread post by Skinjob »

I know it's kind of a late reply, but I thought I'd chime in. Something doesn't sound right with your playlist load times. I'm running my server on a little Zotac ZBox mini-PC with just an AMD E-350 APU (1.6GHz dual-core) and a 5400rpm notebook HD. I have a 796 track playlist that takes 10 seconds from the time I hit "play" on the playlist page until playback actually starts, and that includes transcoding from FLAC to MP3. Also, that's across the internet, not the local LAN. The FLAC files are on an external 2TB eSATA drive, but Madsonic (with the DB containing the playlists) is on the slow notebook drive.

Pretty much any average desktop PC ought to be able to beat that time, so there must be some kind of problem in your configuration/environment.
These users thanked the author Skinjob for the post:
Madsonic
Rating: 7.69%

Post Reply