Album Missing from Search and Artist View

Need help? Post your questions here.
Memphis Foundry
Posts: 3
Joined: 19 Jul 2013, 05:12
Has thanked: 2 times
Been thanked: 0

Album Missing from Search and Artist View

Unread post by Memphis Foundry »

Hello -- I recently moved over from Subsonic to Madsonic. My main question so far has been "why did I wait so long!?" :D

By way of background, I've got a Subsonic Premium license old enough to be grandfathered, and I primarily use iSub on my iPhone, SubGadget on my Win7 laptop, Minisub in Chrome, and the MadSonic web interface using the MadSonic (SigelSonic) theme with the HTML5 player enabled. I'm running MadSonic version 5.0.3572.beta4 on jetty-6.1.x, java 1.7.0_21, Windows 7 (148.4 MB / 193.4 MB).

I recently ripped an older CD that I bought -- "Give Till It's Gone" by Ben Harper. The media is present in the folder where I stored it, and MadSonic appears to be picking it up on scan because the album row exists in the DB. However, the album shows up as PRESENT = false in the database even though the path it lists for the album is correct and functional -- here's the result of a query with another Ben Harper CD listed alongside for comparison:

Code: Select all

ID	PATH	NAME	NAMEID3	SETNAME	ARTIST	SONG_COUNT	DURATION_SECONDS	COVER_ART_PATH	PLAY_COUNT	LAST_PLAYED	COMMENT	CREATED	LAST_SCANNED	PRESENT	ALBUMARTIST	MEDIAFILEID	GENRE	YEAR
245	F:\Audio\flac\Ben Harper\Fight for Your Mind	Fight for Your Mind	Fight for Your Mind	Fight for Your Mind	Ben Harper	14	4077	F:\Audio\flac\Ben Harper\Fight for Your Mind\folder.jpg	0			2010-10-13 22:01:39.937	2013-08-18 21:00:48.299	true		4471	Rock	1995
246	F:\Audio\flac\Ben Harper\Give Till It's Gone	Give Till It's Gone	Give Till It's Gone	Give Till It's Gone	Ben Harper	11	2988	F:\Audio\flac\Ben Harper\Give Till It's Gone\folder.jpg	0			2013-08-03 22:26:58.188	2013-08-03 22:30:15.506	false		4482	Pop/Rock	2011
As you would expect, when you browse or search for this album in any MadSonic interface, it does not appear.

My first suspicion, of course, is that the single-quote/apostrophe could be causing the issue. Has anyone run into anything like this running the latest beta? I'd be happy to provide any additional data for troubleshooting purposes.

Thanks!

gurutech
Contributor
Contributor
Posts: 323
Joined: 02 Jan 2013, 04:56
Has thanked: 11 times
Been thanked: 105 times

Re: Album Missing from Search and Artist View

Unread post by gurutech »

That single quote was my first guess also, but not sure how it could be fixed.

Memphis Foundry
Posts: 3
Joined: 19 Jul 2013, 05:12
Has thanked: 2 times
Been thanked: 0

Re: Album Missing from Search and Artist View

Unread post by Memphis Foundry »

Interesting -- I re-ripped the CD with no single quotes in the folder name, re-scanned my collection, and both versions of the CD appeared. Deleted the version without the single-quote and the properly-named one stayed in the collection. So far, so good.

Post Reply