Trouble after initial install

Need help? Post your questions here.
wpjonesnh
Posts: 2
Joined: 10 Jan 2013, 00:03
Has thanked: 2 times
Been thanked: 1 time

Trouble after initial install

Unread post by wpjonesnh »

First off I want to say (even with coming out of the gate) This mod rocks. I am having a few issues after doing a fresh install. Switching from the regular subsonic and using the war package with Tomcat7 on debian linux. After startup and initial scan I went to change the admin password and got an error:
Error
Subsonic encountered an internal error. You can report this error in the Subsonic Forum. Please include the information below.

Exception org.apache.jasper.JasperException
Message jsp/userSettings.jsp (line: 141, column: 4) "${not command.new and not command.admin}" contains invalid expression(s): javax.el.ELException: Failed to parse the expression [${not command.new and not command.admin}]
Java version Oracle Corporation 1.7.0_03
Operating system Linux 2.6.32-5-amd64
Server Apache Tomcat/7.0.28
Memory Used 59 of 76 MB
I then went to the personal tab and got another error:
Error
Subsonic encountered an internal error. You can report this error in the Subsonic Forum. Please include the information below.

Exception org.apache.jasper.JasperException
Message /WEB-INF/jsp/personalSettings.jsp (line: 39, column: 20) "${default}" contains invalid expression(s): javax.el.ELException: Failed to parse the expression [${default}]
Java version Oracle Corporation 1.7.0_03
Operating system Linux 2.6.32-5-amd64
Server Apache Tomcat/7.0.28
Memory Used 51 of 76 MB
In some folders, I have no problem playing music and on some I do

Error
Subsonic encountered an internal error. You can report this error in the Subsonic Forum. Please include the information below.

Exception javax.el.ELException
Message Failed to parse the expression [${class}]
Java version Oracle Corporation 1.7.0_03
Operating system Linux 2.6.32-5-amd64
Server Apache Tomcat/7.0.28
Memory Used 49 of 76 MB
Is it possible the deployment of the war package was not successful or a permissions issue somewhere? I tried moving the subsonic/db folder out of the way and restarting so I new one would be created but that did not help either. :oops:

Thanks for an awesome mod and regards!

gurutech
Contributor
Contributor
Posts: 323
Joined: 02 Jan 2013, 04:56
Has thanked: 11 times
Been thanked: 105 times

Re: Trouble after initial install

Unread post by gurutech »

Try updating Java. Mine is up to 1.7.0_10-b18 right now.

User avatar
Madsonic
Administrator
Administrator
Posts: 975
Joined: 07 Dec 2012, 03:58
Answers: 4
Has thanked: 1184 times
Been thanked: 465 times

Re: Trouble after initial install

Unread post by Madsonic »

Works with Tomcat 6 but must reworked for Tomcat 7

best regards

wpjonesnh
Posts: 2
Joined: 10 Jan 2013, 00:03
Has thanked: 2 times
Been thanked: 1 time

Re: Trouble after initial install

Unread post by wpjonesnh »

Tomcat6 it is! Now to play. Thanks for the help! :P

Post Reply