5.2 Build 5300 Not Transcoding Video Stream to Andriod

Post your Server Bug Report
randomevents
Posts: 2
Joined: 30 Oct 2013, 22:39
Has thanked: 0
Been thanked: 0

5.2 Build 5300 Not Transcoding Video Stream to Andriod

Unread post by randomevents » 09 Dec 2014, 17:28

Version 5.2 Build 5300, stand alone install on win2012r2 VM
Clean install from the last version of 5.0, and have tried multiple ffmpeg packages

Hi - since installing the latest version of Madsonic, I've been unable to stream to android devices (latest DSub, MadSonic Apps iwth MXPlayer, VLC, and VPlayer on Android 5.0 and Android 4.4.x). From what I can tell it looks like it's trying queue the selection instead of streaming it.

Downloading to cache works
Raw works (but kinda useless on out of home mobile device)
HLS sorta works (Apple devices Ok, android sound cuts out after a couple of seconds)

I have a 5.0.x install on another server (hooked up to exterior speakers for a jukebox) that works fine once I point it towards the video directories, and has the same transcoding instructions.

Any advice or should I downgrade down to 5.1?

User avatar
DoCC
Contributor
Contributor
Posts: 210
Joined: 25 Feb 2014, 14:41
Location: UpperBavaria : ))
Has thanked: 39 times
Been thanked: 65 times
Contact:

Re: 5.2 Build 5300 Not Transcoding Video Stream to Andriod

Unread post by DoCC » 14 Dec 2014, 15:48

sry man, can't help you , i only have one iOS client .

You could test if the android client from subsonic works - as long as you only have tested madsonics own client.

if there is the same behavior, then i'D downgrade

neodawg
Posts: 9
Joined: 11 Jan 2013, 06:32
Has thanked: 1 time
Been thanked: 3 times

Re: 5.2 Build 5300 Not Transcoding Video Stream to Andriod

Unread post by neodawg » 16 Dec 2014, 04:14

Same issue here, I can play but only with a high bandwidth connection. BSplayer-dont work at all, VLC-just spins, MXplayer-works but at full data rate, RAW-not supported, HLS-not supported.
It looks like it starts up ffmpeg on the server and uses CPU, so its transcoding but its not down-converting the quality of the video to the client. I have the client and server settings set to 200k.

running latest android client
MADSONIC 5.2.5420.20141214.0249 server on 2008r2

randomevents
Posts: 2
Joined: 30 Oct 2013, 22:39
Has thanked: 0
Been thanked: 0

Re: 5.2 Build 5300 Not Transcoding Video Stream to Andriod

Unread post by randomevents » 05 Jan 2015, 08:01

It was a real bummer, but it did make me check out Plex, which I now use for video.

User avatar
Madsonic
Administrator
Administrator
Posts: 940
Joined: 07 Dec 2012, 03:58
Has thanked: 1116 times
Been thanked: 430 times
Contact:

Re: AW: 5.2 Build 5300 Not Transcoding Video Stream to Andri

Unread post by Madsonic » 05 Jan 2015, 11:57

You are right, for Madsonic 6 the whole transcoding must be reworked.

Thanks for report,
Best regards

Post Reply